User: voleil Date: 27 Oct 21 13:51 Revision: d68fde7047113604c5090ba10a9fc067b6b290eb Summary: Updated gradle to 7.3 to fix crashes when creating a project with java 17 TeamCity URL: https://ci.denwav.dev/viewModification.html?tab=vcsModificationFiles&modId=7840&personal=false Index: src/main/kotlin/creator/buildsystem/gradle/GradleBuildSystem.kt =================================================================== --- src/main/kotlin/creator/buildsystem/gradle/GradleBuildSystem.kt (revision a6b414e726ead2f28ce8635f641602ae60d9bd3d) +++ src/main/kotlin/creator/buildsystem/gradle/GradleBuildSystem.kt (revision d68fde7047113604c5090ba10a9fc067b6b290eb) @@ -87,7 +87,7 @@ } companion object { - val DEFAULT_WRAPPER_VERSION = SemanticVersion.release(7, 1, 1) + val DEFAULT_WRAPPER_VERSION = SemanticVersion.release(7, 3) } } Index: src/main/kotlin/platform/fabric/creator/FabricProjectConfig.kt =================================================================== --- src/main/kotlin/platform/fabric/creator/FabricProjectConfig.kt (revision a6b414e726ead2f28ce8635f641602ae60d9bd3d) +++ src/main/kotlin/platform/fabric/creator/FabricProjectConfig.kt (revision d68fde7047113604c5090ba10a9fc067b6b290eb) @@ -71,6 +71,6 @@ override fun configureRootGradle(rootDirectory: Path, buildSystem: GradleBuildSystem) { buildSystem.gradleVersion = - if (semanticMcVersion >= MinecraftVersions.MC1_17) SemanticVersion.release(7, 1, 1) else gradleVersion + if (semanticMcVersion >= MinecraftVersions.MC1_17) SemanticVersion.release(7, 3) else gradleVersion } } Index: src/main/kotlin/platform/fabric/creator/FabricProjectSettingsWizard.kt =================================================================== --- src/main/kotlin/platform/fabric/creator/FabricProjectSettingsWizard.kt (revision a6b414e726ead2f28ce8635f641602ae60d9bd3d) +++ src/main/kotlin/platform/fabric/creator/FabricProjectSettingsWizard.kt (revision d68fde7047113604c5090ba10a9fc067b6b290eb) @@ -258,7 +258,7 @@ } if (conf.loomVersion >= SemanticVersion.release(0, 7)) { // TemplateMakerFabric incorrectly indicates loom 0.8 requires Gradle 6... - conf.gradleVersion = SemanticVersion.release(7, 1, 1) + conf.gradleVersion = SemanticVersion.release(7, 3) } conf.environment = when ((environmentBox.selectedItem as? String)?.toLowerCase(Locale.ROOT)) { "client" -> Side.CLIENT Index: src/main/kotlin/platform/forge/creator/ForgeProjectCreator.kt =================================================================== --- src/main/kotlin/platform/forge/creator/ForgeProjectCreator.kt (revision a6b414e726ead2f28ce8635f641602ae60d9bd3d) +++ src/main/kotlin/platform/forge/creator/ForgeProjectCreator.kt (revision d68fde7047113604c5090ba10a9fc067b6b290eb) @@ -180,7 +180,7 @@ } companion object { - val FG5_WRAPPER_VERSION = SemanticVersion.release(7, 1, 1) + val FG5_WRAPPER_VERSION = SemanticVersion.release(7, 3) } }